Degraded Streaming for Broadcast Live Events in the US Region

Incident Report for JWX

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 13:49 UTC

Identified

We have identified the issue and are working to restore full streaming performance. We will continue to monitor the situation.
Posted Jul 28, 2026 - 10:13 UTC

Investigating

We are experiencing degraded streaming in the US region, we recommend streaming out of the EU region.
Posted Jul 28, 2026 - 02:46 UTC
This incident affected: Live Channels.